Announcement

Collapse
No announcement yet.

Front-end CSS builder is not showing.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Front-end CSS builder is not showing.

    Hi!


    I have a problem with the Front-end CSS Builder not showing (and neither is the wp-adminbar for each page and post).

    The issue here is most likely a corrupt install of Wordpress. Before I migrate the site and build it once again - I'd like to check if there is any way to solve it so that I can see any type of css-editor on the frontend.

    I installed Wordpress with the hosting provider's one-click-install-option from their control panel.
    The day before I installed yet another site with the same provider using this one-click-install and that one is working flawlessly using the same configuration of Geneis/Dynamik. Turning off the Dynamik-theme or even all the plugins won't solve the matter, so I think there must be some conflict or missing code in the default WP-settings.

    Support at the hosting provider suggested I try a manual update of Wordpress, using FTP I deleted the folders WP-admin and WP-includes and copied in a new fresh install of those two folders only. This didn't help anything. PHP-error-reporting and Wordpress debugging showed that one plugin didn't work with PHP-version7, so it was changed to version 5.6.

    I tried to install css-editor-plugins, but these won't work in the live editor, since the live editor in Appearance - Customize shows an error: "Your session has expired. Please log in to continue where you left off."

    Using the css-editor in Firefox probably isn't going to work, it won't find the proper css-file to edit.
    Error in the console: "wp-content/uploads/dynamik-gen/theme/dynamik-min.css" could not be loaded.

    Any tips or help would be greatly appreciated. I think migrating the site seems like the only sane solution here.

  • #2
    We can´t solve this from frontend in forum, Nixie B . I´d highly recommend to file a ticket with support staff and let them log in to your installation (or try at least, as it sounds to me like it isn´t really related to Dynamik and your hosting provider should help instead - log files should reveal some insight normally).

    Comment


    • #3
      Thanks for your quick reply, SiGa!

      True, you need to be logged into the installation to fix it. I guess I was hoping for this to be a known issue and adding some code would force the Dynamik css-editor back into the frontend.
      I'll file a ticket with support staff.



      Comment


      • SiGa
        SiGa commented
        Editing a comment
        A known issue with CSS Builder not working is JS conflicts with other plugins. As your troubleshooting already included deactivation of all plugins and replacing of wp folders, that possibility is out, I would say, and code can only be provided if we can look at the problem (I just doubt that code would help here, but might be wrong)....

    • #4
      Thank you for your insight, SiGa!

      Comment


      • SiGa
        SiGa commented
        Editing a comment
        You´re welcome. Good luck, and let us know what the culprit was when you manage to solve it - might help others, too.

    • #5
      I found the issue, there was a mismatch in the Dashboard General Settings.

      WordPress Address (URL): http://www.example.com
      Site Address (URL): http://example.com

      I had installed Wordpress in the root folder at my host (not www-folder). The site still worked as usual before I fixed the typo, just that the adminbar was missing.
      At this point I had nuked the site and was installing each plugin sequentially to see if I found a conflict. When I tested the URLs under the settings, I found the issue.

      Luckily I was able to copy my backup of the site via FTP and didn't have to build it once again after I found the error.

      Comment


      • SiGa
        SiGa commented
        Editing a comment
        Glad you found it, thanks for sharing!
    Working...
    X