Announcement

Collapse
No announcement yet.

Updated Simple Social Icons in Primary Menu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updated Simple Social Icons in Primary Menu

    Hi all,

    Need some instruction if you would be so kind. I've done many searches and can't find a recent solution to putting the Simple Social icons (Genesis plugin - v. 2.0.1) I'm lost to tell you the truth. I was reading this post, http://cobaltapps.club/forum/main-ca...?p=675#post675
    but it's from 2013 and before I mess around I want to make sure it's all good in the current versions of Genesis & Dynamik.
    This is the test site. I'd like to eliminate sidebars on a couple of the pages but still have social icons available (nav).
    http://7d9.056.myftpupload.com/
    Thank you!!
    ~Kitty

  • #2
    I did some quick googling and found this: https://www.youtube.com/watch?v=9O2zuwmkdH8
    Gives you a widget area which is actually in primary nav. Don´t see any reason this shouldn´t work in Dynamik (you might just have to adjust the CSS to your needs, regarding mediaqueries for mobiles also).
    PHP goes to Dynamik Custom - Functions (with admin checkbox checked) and CSS goes to Dynamik Custom - CSS.

    The CSS method in the thread you found should work, too, but I usually prefer to not work with negative margins whenever possible. It´s a bit wonky sometimes.
    Last edited by SiGa; 01-10-2017, 06:47 PM.

    Comment


    • #3
      Ahh, I did watch that one - just copied Srikat's github! Excellent. Thanks for checking that (is it Sylvia?)
      Now I feel better about trying it.
      Thank you!!
      Last edited by SiGa; 01-10-2017, 06:51 PM.

      Comment


      • SiGa
        SiGa commented
        Editing a comment
        You´re always welcome. (It´s Silvia)

      • SiGa
        SiGa commented
        Editing a comment
        Oh, just to add that: Problem that might arise at some point is space in nav bar, depending on number of menu items and number of social icons. You´ll have to keep an eye on that.

    • #4
      Well, after I did it I then got a Parse error ---
      Parse error: syntax error, unexpected 'social' (T_STRING) (in the dynamik-gen/functions.php)
      I just switched out the for the orig file again. I actually think it was cached and still in the edited functions file. (stupid host) But with that said, was I supposed to install the Simple Social plugin, right? and I placed it in an existing widget (not correct placement) then I added Srikat's code.

      I have to figure something else out.

      **************Yay! I just did the Font Awesome icons. fine n' dandy
      Last edited by kittykitty; 01-11-2017, 12:12 AM.

      Comment


      • SiGa
        SiGa commented
        Editing a comment
        Could it be you deleted the original two lines in Functions when you pasted the code in?

    • #5
      I´ve thrown in that code on one of my playgrounds and it works as expected, shows the widget area in Appearance - Widgets and didn´t throw any errors.

      Two things: Make sure you copy everything (don´t miss a closing bracket or something like that) and don´t delete the two lines displayed in default "Functions" tab when you paste that code in. And you should never have caching on while writing any code (no matter if CSS, JS or PHP) - deactivate any related plugin and clear cache before you start.

      It does not matter if you install the Simple Social Icons plugin before or after that. The created widget area would accept anything you drag in there (so you could test with a text widget, too, or use a different plugin or display something else even, if there´s space).
      I´ve tested it with a Search widget and that worked fine.

      And when you simply change 'primary' to 'secondary', the code would work for the secondary nav, too.
      Last edited by SiGa; 01-11-2017, 12:32 PM.

      Comment


      • #6
        Thanks for taking the time to reply Silvia!

        Comment

        Working...
        X