Announcement

Collapse
No announcement yet.

500 Internal Server Error only when Dynamik is activated.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 500 Internal Server Error only when Dynamik is activated.

    Hello Everyone!

    This is my first time asking for help in the forums, but I would appreciate any insight into the matter. I have a long term client that has been on Dynamik for a few years now problem free. However, her site got incredibly outdated and she came to me to get everything caught up. After updating everything (core, Genesis, plugins), I realized her site was busted. I reverted it back to the backup copy I made and started again, more carefully. I managed to get almost everything updated, but I was still having trouble with getting Ninja forms to work. I thought it was causing a 500 error. Finally I got frustrated with it and Put Contact Form 7 in instead, but it still caused a 500 error. At the time, I was doing this via FTP. I started test inside of WordPress, and I quickly realized that any plugin I try to add fails with this error "Installation failed: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> 500 Internal Server Error Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request". So I reverted her site back to a default theme and I was able to add plugins normally again. Contact forms would work. But as soon as I turn Dynamik back on, it will get a 500 error anywhere in the admin panel if I have a contact form plugin of any kind activated, and if I don't, I cannot install any plugins without that error. I've tried creating a fresh re-installation of Dynamik from the Cobalt Apps website and I still can't get past the error. I'm not sure what else I can do outside of re-building her site without Dynamik, but I really dislike that idea.

    For reference, the plugins I have installed currently are:
    Advanced Custom Fields Pro
    Black Studio TinyMCE Widget
    Custom Post Type UI
    ManageWP Worker
    Page Builder by SiteOrigin
    Soliloquy Lite
    Squelch Tabs and Accordions Shortcodes
    TablePress

    For the time being I've removed any cache or security plugins because I'm really trying to avoid adding extra layers of conflict until I get this straightened out again.

    Please, I would be grateful for any suggestions. Thanks in advance

    -Digitalchique

  • #2
    Welcome, digitalchique !
    Seeing I used both contactforms you mentioned and they worked perfectly well, I would doubt they´re the cause of the problem. That Doctype looks odd. Could it be the client or a former dev has put code in Dynamik (or the Genesis script boxes) that could cause this - did you check? (Dynamik Custom tabs or Dynamik Design - Skins - skin CSS/PHP/JS files)?

    I don´t know if you noted the yellow box on top of this page, but it´s essential to understand that this is not a support forum. We are members and volunteers and we can well handle problems we can inspect on frontend here, but for backend problems it´s always better to file a ticket with support staff and let them log in to see and test the problem. I´d suggest you do that and add a link to this thread (or copy/paste) so you don´t have to write it all again. Eric and his team are ususally quick to help.

    Good luck!

    Edit: A quick google of the error looks like it's some sort of SSL authentication problem, if that helps you at all.
    Last edited by SiGa; 03-11-2017, 09:59 AM.

    Comment


    • #3
      Thanks for your response SiGa. I'm the only dev that has ever worked on this project, and I haven't put too many custom modifications in for this particular client. Although I know anything is possible, I don't see anything I've done that's very weird. It's mostly just custom CSS, and a few lines of PHP to modify the footer and query a post type.

      I agree, I think it's a good idea to file a help ticket. I wanted to check here in the forums first in case maybe I stumbled across someone who has experienced this before. I tried Googling it but I'm thinking maybe I was being too specific about my search because I didn't get any helpful responses from my search results. I will definitely Check into the SSL bit. Thanks for the suggestion!

      Comment


      • #4
        Yeah, Google didn´t bring up much for me either (two threads that mentioned a possible relation to SSL in between those) - I´m around in this forum for a while now and this error you mentioned is pretty new to me though. You could try to remove the PHP code temporarily to test if there is any interference. I don´t think CSS could cause this, but PHP is well capable. Do you have debug mode on - it might display something useful? Did you have a look at the error log file?

        We had some threads with problems related to old PHP versions and hostings not displaying the correct PHP version so that´s another thing you might want to check. But all in all, support staff is surely the better way to go with. Let us know!

        Comment


        • #5
          I would look at file permissions. I have a little script that I use in a bash, but most FTP clients will allow you to do permissions to various extents.

          Comment


          • #6
            I did check the permissions, those were okay. Thank you for that suggestion!

            I'm still not entirely sure where the whole HTML 2.0 bit came from, but I did end up moving her website to my VPS with PHP 7 and MySQL 5.6, which seemed to resolve nearly everything. She was hosting on iPage and they were running old versions of PHP and unable to meet the minimum requirements for WordPress.

            I never did get Ninja Forms working again either. When installed (even after I moved her site to my VPS), submitted forms would result in the 500 error. I ended up replacing it with Contact Form 7 and that worked fine.

            It's possible the issue isn't resolved completely and it could rear it's head again, but for now it seems to be at peace.

            Comment


            • #7
              That 500 server error is a generic error that gets shown, but it is possible that your Apache logs have more detailed information.

              Is it PHP 7.1 by any chance? There was a backwards incompatibility in PHP 7.1. It was fixed in core a while ago, but I've seen some themes and plugins that still need to be updated. I think this was the ticket:

              https://core.trac.wordpress.org/ticket/37071

              Comment

              Working...
              X